Solution Number: 1111
Title: Updating the COMSOL Model Library
Platform: All Platforms
Versions: All versions
Categories: Installation
Keywords: Model Library Update

Problem Description

COMSOL Multiphysics contains an update service that enables you to download new models, full models, as well as updated/corrected models to your existing Model Library. This solution explains how it works and provides a troubleshooting section.

Solution

COMSOL 5.1 and later

The Model Libraries is now included in the Application Libraries. For a full description of how to update your Application Library and troubleshoot any problem that might occur, please refer to the section The Application Library Update Window in the COMSOL Multiphysics Reference Manual.

COMSOL 4.4 - COMSOL 5.0

  • The COMSOL Model Library is a collection of tutorial models that are available as part of the software installation. Access the Model Library by selecting the menu File > Model Libraries (Windows) or Windows > Model Libraries (Linux and Mac).
  • When you see the Model Libraries window, you can browse for, and open the model and/or view the model PDF documentation.
  • In the search field, you can type a word to search for: a file name, a string in the model description, or a feature name and tag. Try searching for "copper".

Updating the Model Library

Model Library Update is included as a service in COMSOL Multiphysics. Update the Model Library to get new as well as updated/corrected models installed. Note that model library updates are only published for the current major release of COMSOL.

For a successful Model Library Update you must

  • be connected to the Internet,
  • start COMSOL as administrator (in Windows, right-click the COMSOL icon and select Run as Administrator),
  • have write access to the COMSOL installation directory. On most multi user Linux system this prompts for the system administrator to do the Model Library Update.

If you are installing the program from a DVD, many of the models are made to be compact. Compact MPH-files include all settings for the model but come without built meshes and solution data (a few compact MPH-files have no solutions for other reasons). You can open these models to study the settings and to mesh and re-solve the models. It is also possible to download the full versions—with meshes and solutions—of most of these models through COMSOL Model Library Update. Full MPH-files include all meshes and solutions. In the model library these models display with a full blue circle icon.

To open the Model Libraries window: Windows users: From the Home ribbon, click Model Libraries or select Model Libraries from the File menu. Cross platform users (Mac and Linux): On the Main toolbar, click the Model Libraries button or select Windows>Model Libraries

To open the Model Library Update window: Windows users: From the File>Help menu, select Update COMSOL Model Library. Cross platform users (Mac and Linux): From the Help menu, select Update COMSOL Model Library.

Then follow the instructions in the view that appears. It is also possible to download the full version of a specific model by right-clicking the compact model in the Model Libraries window and selecting Download Full Model (for versions COMSOL 4.3b and later).

For more information, you can search the Help (press F1 in COMSOL Multiphysics), or open the electronic Documentation (press Ctrl F1 in COMSOL Multiphysics) and then go to the COMSOL Multiphysics Reference Manual > The COMSOL Modeling Environment > The Model Libraries Window>The Model Library Update Window.

COMSOL 4.3b and earlier

Access the Model Library by selecting the menu View > Model Library (COMSOL 4.2 to 4.3b) or File > Open Model Library (COMSOL 4.1 and earlier). When you see the Model Library window, you can browse for, and open the model and/or view the model PDF documentation. In the search field, you can type a word to search for: a file name, a string in the model description, or a feature name and tag. Try searching for "copper".

To update the Model Library, click the Model Library Update button in the Model Library settings window, select the menu View > Model Library Update, or Options > Model Library Update (COMSOL 4.1 and earlier).

Follow the instructions in the view that appears. It is also possible to download the full version of a specific model by right-clicking the compact model in the Model Library list and selecting Download Full Model (COMSOL 4.3b and later).

Troubleshooting

If you get the error message:

Error contacting the update server

see solution 1126.

Older Versions

Access the Model Library by selecting the menu View > Model Library (COMSOL 4.2-4.3b) or File > Open Model Library (COMSOL 4.1 and earlier).

To update the Model Library, click the Update Model Library button in the Model Library window, select the menu View > Model Library Update (COMSOL 4.2-4.3b), or Options > Model Library Update (COMSOL 4.1 and earlier)


Disclaimer

COMSOL makes every reasonable effort to verify the information you view on this page. Resources and documents are provided for your information only, and COMSOL makes no explicit or implied claims to their validity. COMSOL does not assume any legal liability for the accuracy of the data disclosed. Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark details.