Discussion Closed This discussion was created more than 6 months ago and has been closed. To start a new discussion with a link back to this one, click here.

Unable to replicate results from COMSOL 4.4 onto 5.3

Mamadou Diallo

Please login with a confirmed email address before reporting spam

I am trying to simulate electrical field in 2D with a rotating source.

I setup the model some times ago and working with the expected output.

I tried running the same model in COMSOL 5.3. The electric potential surface plot is correct but the probe table plt is completely wrong.

I rerun the same file in COMSOL 4.4 and getting the correct results.

I have attached the results here and the model file (Comsol 5.3).

Thnaks for the help.



2 Replies Last Post 11:03 GMT-05:00 12. jan. 2018
Magnus Ringh COMSOL Employee

Please login with a confirmed email address before reporting spam

Posted: 6 months ago 09:45 GMT-05:00 12. jan. 2018

Hi,

In the Study Settings section of the Settings window for the Parametric Sweep node, specify

deg

in the Parameter unit field so that the parameter values from 0 to 360 are interpreted as degrees and not radians, which is the default unit for angles apart from the geometry sequence, where you can specify if you want to use degrees or radians. Then the probe table plot will look correct.

Best regards, Magnus Ringh, COMSOL

Hi, In the **Study Settings** section of the **Settings** window for the **Parametric Sweep** node, specify deg in the **Parameter unit** field so that the parameter values from 0 to 360 are interpreted as degrees and not radians, which is the default unit for angles apart from the geometry sequence, where you can specify if you want to use degrees or radians. Then the probe table plot will look correct. Best regards, Magnus Ringh, COMSOL

Mamadou Diallo

Please login with a confirmed email address before reporting spam

Posted: 6 months ago 11:03 GMT-05:00 12. jan. 2018

Hi,

In the Study Settings section of the Settings window for the Parametric Sweep node, specify

deg

in the Parameter unit field so that the parameter values from 0 to 360 are interpreted as degrees and not radians, which is the default unit for angles apart from the geometry sequence, where you can specify if you want to use degrees or radians. Then the probe table plot will look correct.

Best regards, Magnus Ringh, COMSOL

Thank you Magnus for the quick response.

>Hi, > >In the **Study Settings** section of the **Settings** window for the **Parametric Sweep** node, specify > >deg > >in the **Parameter unit** field so that the parameter values from 0 to 360 are interpreted as degrees and not radians, which is the default unit for angles apart from the geometry sequence, where you can specify if you want to use degrees or radians. Then the probe table plot will look correct. > >Best regards, >Magnus Ringh, COMSOL Thank you Magnus for the quick response.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.